Forum

Legion support beta...
 

Legion support beta release follow up  

Page 11 / 15
  RSS
redboxphen
(@redboxphen)
Active Member

Jeromnimo wrote:

Hi all,

after a long silence, beta 9 is out, allowing BfA opening!

You can grab this version as usual on download site here : https://download.wowmodelviewer.net/

Please raise any issue you would encounter.

Thanks a lot to Wain for his continous contribution on this release.

Ayy I was starting to worry something happened to you after the long silence on the board! Hope everything's well, and as always thanks for all your hard work.

ReplyQuote
Posted : 09/07/2018 3:04 pm
Zensunim
(@zensunim)
New Member

Jeromnimo wrote:

after a long silence, beta 9 is out, allowing BfA opening!

Please raise any issue you would encounter.

Thank you for the update and for fixing the character import! :D

I found that trying to load the following models causes client crashes with Beta9:

Creature->Druidbear2


  • druidbear2_artifact2.m2

  • druidbear2_artifact3.m2

  • druidbear2_artifact4.m2

(1, 5, and 6 work)

Creature->Druidcat2


  • druidcat2_artifact1.m2

  • druidcat2_artifact2.m2

  • druidcat2_artifact3.m2

  • druidcat2_artifact4.m2

  • druidcat2_artifact5.m2
ReplyQuote
Posted : 09/07/2018 7:26 pm
Melkyore
(@melkyore)
Active Member

Hey and thanks for your order workd !

Few weeks/months ago, you fixed the problem with gloves and boots (they were very simple with no details etc)

On your new version details are here but they are flying, never at the right place !

<a href=" https://imgur.com/a/hTzJ53 6" class="bbcode_url"> https://imgur.com/a/hTzJ536

ReplyQuote
Posted : 10/07/2018 5:20 pm
moredreadd
(@moredreadd)
New Member

Is it possible to open BfA files without having the beta? Like can I open pre-loaded files for 8.0 and see models from BfA?

ReplyQuote
Posted : 10/07/2018 8:43 pm
Silencer
(@silencer)
Estimable Member

Odd for some reason Beta 9 does not open any model for me 7.3.5 or 8.0...

Wish the logs say more what's the problem.

Still glad to see that WMV is stil alive! Thanks for all hard work Jeromi !

Update: Funny, got this solved.

THe problem was listfile.

I am using my own listfile that is better in some way :)

Example: CamerasFlybyBloodElf.m2

WMV: Cameras/FlybyBloodElf.m2

Can you support both slashes ?

ReplyQuote
Posted : 10/07/2018 8:43 pm
josephstylin
(@josephstylin)
New Member

Downloaded the latest beta last night. It all worked fine. Go to use it today and Windows Defender has it flagged and removed the executable.

Trojan:Win32/Cloxer.D!cl

Affected items:

file: C:Program Files (x86)WoWModelViewerwowmodelviewer.exe

Anyone else experiencing this?

ReplyQuote
Posted : 11/07/2018 3:38 pm
WollieWoltaz
(@wolliewoltaz)
Estimable Member

Same here. Worked yesterday and now I says it contains a virus :(

ReplyQuote
Posted : 11/07/2018 5:21 pm
Wain
 Wain
(@wain)
Reputable Member

Silencer wrote:

Odd for some reason Beta 9 does not open any model for me 7.3.5 or 8.0...

Wish the logs say more what's the problem.

Still glad to see that WMV is stil alive! Thanks for all hard work Jeromi !

Update: Funny, got this solved.

THe problem was listfile.

I am using my own listfile that is better in some way :)

Example: CamerasFlybyBloodElf.m2

WMV: Cameras/FlybyBloodElf.m2

Can you support both slashes ?

The weird thing is I thought we did support both :/ I wonder if it's us, or a recent change to CascLib (which we include from another project). - Since the latest version of Ladik's CascView still supports backslash files, I think it's unlikely CascLib is at fault and it's probably us.

I have identified another listfile bug in this release: the file trees and menus are now displaying all file names that are listed in the listfile, even if those files aren't in the actual database. As a result the file tree has a lot of dummy file names.

ReplyQuote
Posted : 11/07/2018 6:46 pm
Wain
 Wain
(@wain)
Reputable Member

WollieWoltaz wrote:

Same here. Worked yesterday and now I says it contains a virus :(

The fact it was fine and became suspicious makes it sound like an update to Windows Defender has made it a false positive :( I can't say that for sure, of course, but AVG hasn't identified any problems for me.

ReplyQuote
Posted : 11/07/2018 6:48 pm
Wain
 Wain
(@wain)
Reputable Member

Wain wrote:

The weird thing is I thought we did support both :/ I wonder if it's us, or a recent change to CascLib (which we include from another project). - Since the latest version of Ladik's CascView still supports backslash files, I think it's unlikely CascLib is at fault and it's probably us.

I tested Beta 8 (the previous Beta from Feb.) and it doesn't support backslashes either. It reads files with backslashes because it can render their paths in the file tree, but it can't find the model when you click on one. Kind of odd. We need to either support backlashes properly, or remove the partial support completely and warn the user. This half-way thing hides the problem and makes it look like the database is broken.

ReplyQuote
Posted : 11/07/2018 7:48 pm
WollieWoltaz
(@wolliewoltaz)
Estimable Member

So what can we do? Should we wait for a new release or can we do somehting within windows defender?

ReplyQuote
Posted : 11/07/2018 8:07 pm
Wain
 Wain
(@wain)
Reputable Member

I've submitted fixes for support of Windows paths in listfile, and also for the bogus filenames showing up in the model list. Hopefully Jeromnimo approves them :)

As for Windows Defender, I can't say, sorry :( . I have no experience with it. I can't even say for sure that this is a false positive, though I expect it will be.

ReplyQuote
Posted : 11/07/2018 9:41 pm
WollieWoltaz
(@wolliewoltaz)
Estimable Member

Well there are many more who encountering the virus problem on the machinima discord when downloading the latest beta release. It's a trojan virus..

Trojan:Win32/Cloxer.D!cl

Is this something that needs to be fixed with modelviewer itself? Because this never occured with older releases.

ReplyQuote
Posted : 13/07/2018 4:35 pm
Wain
 Wain
(@wain)
Reputable Member

It's odd. I've put an alert on your report in case it means Jeromnimo sees it sooner.

I wonder if anyone on that Discord can build their own from the repository and if they still see the error in the copy they build themselves.

ReplyQuote
Posted : 13/07/2018 8:25 pm
Jeromnimo
(@jeromnimo)
Noble Member

Thanks for this notification, I am using Avast as an antivirus on my side, and nothing is raised. I have sent a false positive report to Microsoft, hopefuly they will arrange situation.

According to Virus Total, file is OK (5 false positive)

https://www.virustotal.com/#/file/9f5139841309976b8058e854a08cf65ac0ca23e38b5a0c53b7657c1d30beda98/detection

but you're right, previous setup (beta8), only 2 false positive

https://www.virustotal.com/ui-public/index.html#/file/f2a5159e7afe1ecc633dc8c347078ae628bfed272f2dce5c30f6c058b6561226/detection

Overall, file is safe, I always install it locally on my pc to try before putting it online

Please use JIRA (same account credentials than forum) to enter bugs !
If you like this software, feel free to donate : EURO or USD. Thanks !

ReplyQuote
Posted : 15/07/2018 12:17 pm
Page 11 / 15
Share:
Top
en_USEnglish
fr_FRFrançais en_USEnglish
  
Working

Please Login or Register