Uploaded image for project: 'WowModelViewer'
  1. WowModelViewer
  2. WMV-506

Items derived from "collections" models are showing wrong components

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.9.0
    • Component/s: None
    • Labels:
      None
    • Platform:
      Windows 10
    • Platform type:
      64 bits

      Description

      For armour items that are derived from "collections" models (and are merged into the main model), currently a lot of the unwanted geosets are being switched on, and sometimes not showing ones they should.

      For example, for the Mesmerizing Soul Hood:
      https://www.wowhead.com/item=152351/mesmerizing-soul-hood&bonus=3614:1472#modelviewer:1+0

      which uses collections_cloth_raidmage_s_01_<race/sex>.m2 , the arm and boot sections are being displayed when only the head section should be.

      It seems to be the case with other collections items I've tested and I don't understand what's going on. I've tried hiding all geosets for those merged items, but they are switched back on somewhere.

        Attachments

          Activity

            People

            • Assignee:
              Wain Wain
              Reporter:
              Wain Wain
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: